一、本章前言:   

之前小闻带领大家学习了软路由如何安装PVE的教程,我们经过千辛万苦安装好PVE,但是有点小瑕疵,就是我们每次远程登录PVE的时候,欢迎页面提示我们“提示没有有效的订阅You do not have a valid subscription for this server. Please visit www.proxmox.com to get a list of available options”,因为用的是免费版的,所以每次都提示这个没有有效的订阅.这个问题也不是什么大问题,但是每次提示这个有点让人很反感,所以就从网上找到这个方法,亲测有效。

解决方法1:

修改文件/usr/share/javascript/proxmox-widget-toolkit/proxmoxlib.js 修改之前记得先备份一下

然后找到

if (data.status !== 'Active') {

修改为

if (false) {

然后保存,重启网页服务

systemctl restart pveproxy

解决方法2

或者  Ext.Msg.show({修改为 Ext.Msg.noshow({

发表评论

您的电子邮箱地址不会被公开。